19th October 2018

Investigating: Problems with manual uploads

We’re having some trouble with manual uploads and it should be fixed soon.

Update: The problems with the manual uploads that were already imported are fixed. The problem can still occur when you make a new upload. But we are close to fixing this as well.

Update: The problem is fixed for all manual imports