Slow syncs and general slowness of Silverfin
Incident Report for Silverfin
Resolved
We have been dealing with a large number of syncs today which has caused excessive load on the database. After identifying and resolving one particular query that was slow the database load reduced but due to the number of syncs from large companies we then experienced more slowdowns. We now believe this issue is resolved but we will be reviewing the data import process.
Posted May 05, 2021 - 16:39 CEST
Investigating
We are investigating severe slowdown in Silverfin, the database appears to be overloaded.
Posted May 05, 2021 - 13:59 CEST
Monitoring
The code change optimizing the slow query has been deployed. We are still clearing the backlog of background jobs and are monitoring the situation.
Posted May 05, 2021 - 13:10 CEST
Identified
A code change was made that causes more frequent queries to our database. This caused our database to become overloaded and, to protect it, all jobs were automatically slowed down. The problematic query has been optimized and that code change is now being deployed.
Posted May 05, 2021 - 10:59 CEST
Investigating
We are currently investigating an issue related to slow syncs and general application performance.
Posted May 05, 2021 - 08:50 CEST
This incident affected: Silverfin (Silverfin, Syncing, Exports).