Login issue

Incident Report for Silverfin

Resolved

All users should be able to log in again. Please keep reaching out to Support if you are facing troubles. Our apologies for the inconvenience!
Posted Mar 13, 2026 - 11:15 CET

Monitoring

A fix has been implemented, and we are monitoring the results. Could you please try to log in once more? If not, please reach out to Support on support@silverfin.com.
Posted Mar 13, 2026 - 09:30 CET

Investigating

If you are currently unable to log in, we are currently further investigating it.
Posted Mar 13, 2026 - 09:14 CET
This incident affected: Silverfin (Silverfin).