Login issue

Incident Report for Silverfin

Resolved

All users should be able to log in again. Please keep reaching out to Support if you are facing troubles.
Our apologies for the inconvenience!
Posted Jun 23, 2026 - 17:20 CEST

Investigating

We are aware of users facing issues attempting to login - we have identified the cause of the issue. This will be resolved shortly, our apologies for the incovenience!
Posted Jun 23, 2026 - 17:05 CEST
This incident affected: Silverfin (Silverfin).