Login problems

Incident Report for Silverfin

Resolved

We have identified the root cause of the issue and access to the platform has now been restored.

If you continue to experience any new issues, please contact our Support team directly at support@silverfin.com.

We apologize for the inconvenience and thank you for your understanding.
Posted Jul 17, 2026 - 15:07 CEST

Investigating

We are currently receiving reports that users are unable to log in to the platform. Our team is actively investigating the issue. We apologize for the inconvenience and will provide an update as soon as more information becomes available.
Posted Jul 17, 2026 - 14:44 CEST
This incident affected: Silverfin (Silverfin).