Delayed/Slowness on the Platform

Incident Report for Silverfin

Resolved

The platform should be back to its usual speed, as the load on our platform has dropped, we will continue to monitor and follow this up in the following days.
Our apologies for this inconvenience.
Posted Jan 28, 2026 - 17:29 CET

Identified

Our platform is currently under high stress, leading to slow responses and longer load times affecting the overall performance.
Our apologies for this inconvenience.
Posted Jan 28, 2026 - 16:06 CET
This incident affected: Silverfin (Silverfin).