Platform slowness

Incident Report for Silverfin

Resolved

The slowness has been resolved, our sincere apologies for the inconvenience.
Posted Nov 06, 2025 - 12:34 CET

Monitoring

We have resolved the cause of the platform experiencing slowness and are monitoring the situation.
Our apologies for the inconvenience.
Posted Nov 06, 2025 - 12:03 CET

Identified

We have identified what's causing our platform slowness and are working on resolving this as soon as possible.
Our apologies for the inconvenience.
Posted Nov 06, 2025 - 11:39 CET

Investigating

We are aware of our platform experiencing slowness and are looking into the issue to resolve this as soon as possible.
Our apologies for the inconvenience.
Posted Nov 06, 2025 - 11:13 CET
This incident affected: Silverfin (Silverfin).