Slowness Workflows and Reconciliations

Incident Report for Silverfin

Resolved

The cause of the slowness has been resolved.
Once again our apologies for the inconvenience!
Posted Jun 04, 2026 - 14:17 CEST

Identified

We are aware that workflows and reconciliations might be experiencing slowness/failing to load certain parts. We are working on resolving this as soon as possible.
Our apologies for the inconvenience!
Posted Jun 04, 2026 - 11:56 CEST
This incident affected: Silverfin (Silverfin).