Sync update

Incident Report for Silverfin

Resolved

We have monitored the incoming stream of tickets, and the issue now appears to be resolved. Support will still be available for tickets via support@silverfin.com.

Tomorrow, we’ll be available starting at 9 AM via chat. Once again, we apologize for the inconvenience caused, and thank you for your understanding.
Posted Jul 30, 2025 - 16:51 CEST

Monitoring

Our developers have implemented a new update where syncing using the arrows (in the top left or right corner) should now be sufficient.

If this does not work, please provide the names of the files and links so our support team can access the files directly.

We deeply regret the disruption caused and greatly appreciate your patience and understanding during this situation.
Posted Jul 30, 2025 - 10:41 CEST