Login/platform issue

Incident Report for Silverfin

Resolved

The platform should be accessible and working for all users. If noticing any slowness or blocking messages, please reach out to support!
Posted Jul 07, 2025 - 13:27 CEST

Update

We are currently experiencing intermittent networking issues.

We are investigating this. However, it looks like this has an impact on logging into the platform and the sync performance.
Posted Jul 07, 2025 - 11:05 CEST

Investigating

We are currently experiencing intermittent networking issues. We are investigating this.
Posted Jul 07, 2025 - 10:30 CEST
This incident affected: Silverfin (Silverfin).