Silverfin sign-in is broken
Incident Report for Silverfin
Resolved
The incident has been resolved. We will do a thorough investigation of what is causing this problem.
Posted Jul 22, 2021 - 09:02 CEST
Monitoring
We have deployed a fix.
Posted Jul 22, 2021 - 08:59 CEST
Identified
Users are reporting the Silverfin sign-in function to be broken
Posted Jul 22, 2021 - 08:54 CEST
This incident affected: Silverfin (Silverfin).