Delayed platform response

Incident Report for Silverfin

Resolved

As the fix have been implemented, we keep monitoring the system. If you are still experiencing issues, please do not hesitate to contact our support! Our apologies for the inconvenience!
Posted Jan 27, 2026 - 17:03 CET

Monitoring

We have implemented a fix and we are currently monitoring the results.
Posted Jan 27, 2026 - 16:08 CET

Investigating

We have noticed that using the platform is not as responsive as usual which is affecting overall performance. We are investigating this further.
Posted Jan 27, 2026 - 15:36 CET
This incident affected: Silverfin (Silverfin).