Silverfin Access

Incident Report for Silverfin

Monitoring

Our teams have identified the issue and implemented a solution. We are closely monitoring the situation to ensure stability.

We will provide our next update tomorrow, 28/07, at 9:00 AM CET.
Posted Jul 27, 2026 - 17:12 CEST

Investigating

We would like to inform you that we are still investigating the situation. We will provide updates here as soon as we have more information.
Posted Jul 27, 2026 - 16:56 CEST

Monitoring

We have identified the issue and are currently monitoring the situation closely. We will provide updates here as soon as we have more information.

We sincerely apologize for the inconvenience caused.
Posted Jul 27, 2026 - 16:51 CEST

Update

We would like to inform you that our team is still investigating the issue.

In the meantime, you can use the URL "https://auth.getsilverfin.com/" to log in to the platform as a temporary workaround.

We will provide our next update here at 17:00 CET. We apologize for any inconvenience caused and appreciate your patience.
Posted Jul 27, 2026 - 16:36 CEST

Investigating

We are currently receiving reports that users are encountering an error message when attempting to log in to the platform.

Our team is actively investigating the issue and will provide updates on this page as soon as more information becomes available.
Posted Jul 27, 2026 - 15:41 CEST
This incident affects: Silverfin (Silverfin).