Progress status of workflows and reconciliations keep loading
Incident Report for Silverfin
Resolved
The incident has been resolved.
Posted Dec 05, 2024 - 16:19 CET
Identified
We have identified the issue and are deploying a fix already.
Posted Dec 05, 2024 - 15:39 CET
This incident affected: Silverfin (Silverfin).