Workflow access

Incident Report for Silverfin

Resolved

Following the update we provided, the issue with accessing workflows has been resolved and the situation is now stable again.
Posted Mar 25, 2026 - 12:35 CET

Update

We are receiving reports that users are experiencing issues/error message ("There was an issue getting your page") accessing workflows within the files.

Our developers are aware of the issue and are currently investigating it.
Posted Mar 25, 2026 - 12:03 CET

Investigating

We are receiving reports that users are experiencing issues/error message ("There was an issue getting your page") accessing workflows within the files.

Our developers are aware of the issue and are currently investigating it.
Posted Mar 25, 2026 - 09:18 CET
This incident affected: Silverfin (Silverfin).