Delayed platform response

Incident Report for Silverfin

Resolved

The fix have been implemented. We keep monitoring the system. If you are still experiencing issues, please do not hesitate to contact our support! Our apologies for the inconvenience!
Posted Jan 27, 2026 - 09:18 CET

Monitoring

We have implemented a fix and will continue to monitor the situation.
Posted Jan 26, 2026 - 17:35 CET

Identified

We have identified the cause of the issue and are working on resolving this as swiftly as possible. Our apologies for the inconvenience!
Posted Jan 26, 2026 - 17:09 CET

Investigating

We have noticed that using the platform is not as responsive as usual. This is affecting overall navigation, AI mapping screens, and the feedback from Silverfin Assistants. We are investigating this further.
Posted Jan 26, 2026 - 15:21 CET
This incident affected: Silverfin (Silverfin).