Platform slowness

Incident Report for Silverfin

Resolved

We’ve implemented changes that have improved Silverfin performance. We’re continuing to monitor the situation closely due to elevated traffic levels.
Thank you for your patience, and we apologize for the inconvenience.
Posted Jan 30, 2026 - 11:08 CET

Identified

We’re aware that some users have experienced intermittent slowness and performance issues over the past few days.
Our team is actively investigating and working to resolve this for those affected.
We apologise for any inconvenience caused.
Posted Jan 29, 2026 - 08:55 CET
This incident affected: Silverfin (Silverfin).